1099 Build A Binary Search Tree (30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
figBST.jpg
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
关键思路:中序遍历这棵树得到的结点顺序应该是给出的数值序列从小到大的排列顺序
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 101;
struct node {int id;//存储节点编号int data;//存储节点存储的数据int left;//左孩子int right;//右孩子
}no[maxn];
int n;
int k = 0;
vector<int>v(maxn);
void inorder(int root)
{if (root == -1)return;//当该节点为-1,returninorder(no[root].left);no[root].data = v[k++];//中序遍历的结果就是二叉搜索树的从小到大排序inorder(no[root].right);
}
int main()
{cin >> n;for (int i = 0; i < n; i++)//初始化{no[i].id = i;cin >> no[i].left;cin >> no[i].right;}for (int i = 0; i < n; i++)//存储需要插入的数据{cin >> v[i];}sort(v.begin(), v.begin() + n);//排序inorder(0);//中序遍历,0是根节点queue<int>q;int flag = 0;q.push(0);//根节点入队while (!q.empty()){int fa = q.front();q.pop();if (flag++ == 0)cout << no[fa].data;else cout << " " << no[fa].data;//输出格式if (no[fa].left != -1)q.push(no[fa].left);if (no[fa].right != -1)q.push(no[fa].right);}}